Page 1 of 1

Simulink import error

PostPosted: March 9th, 2012, 12:54 pm
by jana
Hi all,

I get the following error when I try to import a Simulink model into the SysML/UML model after I do "import/sync Simulink model" on the "SimulinkBlock":
"Failed to create Flowport type"

I followed all the steps of the "Importing MathWorks Simulink components" instruction: ... nents.html

Does anyone know the solution?


Re: Simulink import error

PostPosted: March 9th, 2012, 1:55 pm
by Farquad
I'm guessing you are using unsupported types on your ins/outs in the simulink model.

Re: Simulink import error

PostPosted: March 14th, 2012, 2:41 pm
by jana
Just to be sure, I ran the PowerWindowWithSimulink sample, which was working before. However, when I "import/sync Simulink model", I get the same error. In the SimDataFile.txt file, Warning messages for all 3 ports appear:
MATLAB_ROOT=C:\Program Files\MATLAB\R2011b
up Inport Warning: The block parameter 'DataType' on 'rhp_powerwindow/up' has been deprecated. Getting the value of this parameter is no longer allowed. You can get the data type using parameter 'OutDataTypeStr' instead.

I made some changes in the generated code addressing the deprecated comment, however, it gives the same error. I installed the latest version of Matlab Simulink, and I guess it's causing a problem. Any hints?

Re: Simulink import error

PostPosted: March 16th, 2012, 12:32 am
by jana
Hey all,

Since I didn't solve the import problem with the Matlab 2011b, I just reinstalled the older version of Matlab (in my case R2007b), and made sure the path of the old version is included prior to the newer Matlab version in the System path as I also need to keep my new Matlab version.

For this, chaim's post is helpful: ... D=14276769

I hope Rational team tackles the above mentioned import problem with the newer versions of Matlab.


Re: Simulink import error

PostPosted: April 1st, 2012, 2:17 pm
by swoloschek
We encoutnered the same error. In talking with IBM there was an API change in MATLAB 2011b. It turns out that Rhapsody has a fix for this. (you wont find it in the fix list.. but we tried it and it now works).

Re: Simulink import error

PostPosted: April 2nd, 2012, 3:37 pm
by jana
swoloschek, thx for sharing this information.